Enviro Mini Board Repair

bubble Posted By bubble, May 12, 2019 at 4:39 PM

  1. bubble

    bubble
    Member 2.
    NULL
    

    Dec 1, 2015
    15
    0
    Loc:
    Berks PA
    This past winter, our 3 year old Mini started to smell like it was overheating....the "new paint smell", if ya know what I mean. Found that the convection fan stopped running. After some testing, found the fan was still good; then decided to attempt a CONVECTION FAN TRIAC replacement. There was NO WAY I wasn't gonna try this before spending $350 or so for a replacement PC board. Ordered triacs (& the opto-isolators that feed them) for the convection & combustion fans. They are fairly cheap, so I bought a several of each. Thought I'd wait for warmer weather to do the repairs. I temporarily bypassed the electronics to run the convection fan directly from the AC power outlet until the day of repairs.

    While waiting for warm weather, the ignitor died. Surprised it only lasted 3 years! Fortunately, I already bought many replacement parts for this thing, and had that laying around. EASY FIX on the ignitor. I also installed an IN-LINE FUSE to the ignitor to protect the PC BOARD if it were to ever short to ground.

    Well today was convection fan repair day. Swapped the triac, and VIOLA! All's well that ends well! See pics (pic labels aren't perfect, but good enough to complete MY fix).

    If there were a sticky for the Enviro Mini, this post belongs in it, lol.

    ENVIRO MINI PC BOARD.JPG Convection Triac Removed.jpg New Convection Triac.jpg
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. BigJohnfromCT

    BigJohnfromCT
    Burning Hunk 2.
    NULL
    

    Dec 29, 2012
    243
    51
    Loc:
    Danbury, CT
    Way to go Bubble. Job well done. Give yourself a pat on the back. Question: how did you know it was the trial and what size soldering iron did you use for your fix? Any problems with the printed circuit paths on the board, i.e. raising from the heat?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. bubble

    bubble
    Member 2.
    NULL
    

    Dec 1, 2015
    15
    0
    Loc:
    Berks PA
    I didn't know it was the triac, lolol. I did believe it stood a good chance that it was, as that's the "HEAVY DUTY" component of the board. So spending $30-ish on the gamble was good odds, IMO. Win some, lose some :). That money also got me the other style triac that the board uses, plus the optocouplers that drive them.

    There are 4 triacs on the board (2 different sized ones). I imagine that each triac feeds one of these functions:
    1) Auger Motor;
    2) Combustion Blower;
    3) Convection Blower;
    4) Ignitor.

    So buying in bulk for all of the above is a cheap chance of lengthening the life of the board.

    I also was worried about the traces lifting (board is etched dual sided). So I bought a Weller soldering station just for this purpose. I actually opened the box today, when I began this task. Starting out at low temp quickly showed me the need to crank things up. The tip is sooooo thin, that I had to max that lil sucker out, haha. The Weller was money well spent. The junk solder wick I bought, on the other hand, wouldn't have absorbed water if it were thrown in the ocean, lol. I ended up using the SLAP method to remove the solder...heat a joint up, then SLAP the board, semi-hard, to splash the solder out, haha. Primitive but effective.

    Soldering Station.JPG
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page