Heat n Glo Delayed Ignition problem - control module?

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.
Not open for further replies.


Jan 6, 2015
We have a Heat n Glo model 6000CMOD-IPI that seems to have a delayed ignition problem which occasionally results in a timeout and us needing to reset the controller. I am wondering if this is likely a defective module (Dexen PN 2166-306, which I can't seem to find anywhere) or gas valve or something else?

Here's what it does:

1. We turn fireplace on with remote and hear clicking... see pilot light within a couple of seconds.
2. Then there's a big delay.. sometimes only 5 seconds if the unit was just on a few minutes ago, and other times much longer, especially if it's the first start of the season.
3. During this delay, pilot remains lit.
4. 90% of the time, the burner finally ignites and everything is good.
5. 10% of the time or less, the unit times out and I have to reset it.

Any thoughts / suggestions? Thanks!


Jan 6, 2015
Make sure the rectifier flame sensor is clean. Steel wool is good for polishing the metal.

Thanks - I tried that, did not make a difference. I should also mention that this unit has had this issue since it was installed several years ago... shame on us for not addressing it then but frankly I just thought they were slow starters and that was the way it was supposed to be...until we got another unit that fires right up.


Full Time RVer
Staff member
Dec 2, 2008
Wherever we're parked
One other check you can do is to make sure the ground wire is snugly seated.



New Member
Jan 14, 2015
Similar problem:
1 yr old unit. Using remote control the Pilot lights but main burner will not, unless I use blow torch to heat up igniter for several seconds. Igniter glows red, then clicking stops, then main burner lights. Works fine but shuts off within approx 12 hrs. Then have to reset electric system by turning off and on again. Is there a timer? I leave pilot lit, which keeps igniter red and re-ignites fine, but pilot seems to shut off also within approx 12 hrs.
Is this a problem requiring cleaning/replacing IPI? Is there also an electrical issue? Any help appreciated.


Minister of Fire
Apr 9, 2008
Central NY
I just solved a similar symptom after getting low readings on the power going into a gas insert. Turns out was run thru a dimmer switch. Took dimmer out of the equation, things worked fine.
  • Like
Reactions: DAKSY


New Member
Oct 29, 2014
That fireplace has a ribbon burner. Make sure there are NO rocks on that burner. If there are there's a good chance of delay ignition. It states it in the manual as well.
Not open for further replies.