Heat n Glo gas fireplace lights then goes out

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.

DK 416

New Member
Jan 2, 2022
I have an older Heat n glo gas fireplace model escape 130-c
It has remote control electronic ignition.
I have lived in this house about 6 years and it worked until about a year ago.
I had it inspected and was determined the pilot assembly should be changed.
I order 2202-013 (the correct heat n glo pilot assembly).
I installed it and it lit fine. I put glass on and it lit fine.
the next day I lit it and it lit fine but shut off after about 10 seconds.
Of course the pilot lights first, stays on and heats the metal rod and then the main fire starts.
now it shuts off after about 10 seconds. what is the problem here?
hoping I don't need to call in a pro. Any suggestion is appreciated.
pic below is of the old pilot assembly before fully removed. Next pic is when it was running fine yesterday.

Heat n Glo gas fireplace lights then goes out Heat n Glo gas fireplace lights then goes out
I just tried it again with glass on and off and does the same. pilot lights, then main fire lights and after a few seconds everything shuts off. The control shows 4 red flashes and one green flash after this happens. I reset the controls and it lights again, but only for a few seconds. It is a new pilot assembly so it should work fine. the gas pressure seems fine as well. I will take a video later and post it. this is the same thing that happened with the old pilot assembly. looking at the manual could be, faulty ground, low pressure, faulty pilot assembly. I don't think it is any of these.
I will move the ground tonight. In meantime I shot some video here:
There was a known problem with these models but I can't remember the specifics.
It had to do with needing a heat shield in the valve area to protect from overheating. I was able to warranty it at the time( about 5 years ago) and received the heat shield and new module.
it looks like there is some shielding you can see in the photos. does this look like the shielding is in place? this fireplace did work fine for about 4 or 5 years when I moved in so I don't think this is the issue...but maybe.
I will change the ground soon and see if that makes any difference.
another note is the other day I did light it with glass in place and it stayed lit for the evening (watched a hockey game).
Bad news. It worked for a day or two then stopped. I figured it must be the ground again even though nothing moved. so redid the ground and back to doing the same thing again. pilot lights, fireplace lights then about 5 seconds later fireplace goes out then pilot. I am thinking maybe I should measure the output from the pilot assembly? any other ideas?
Do you mean there is a switch on the valve that can manually over ride the pilot assembly? I think this is what you mean. or are you referring to the receiver for the remote? I can look and try this.
I don't know which remote you're using, but there is always a switch underneath the firebox for lighting the unit, somewhere...
a repair person just told me on the phone that these units had some issues and they have had to replace the valve and control unit before, because of intermittant problems. I am hoping that is not the case. may contact heat n glo.
ok I went to look again and tried removing all the logs and flame proof material on the bottom of fireplace. I must have had some holes blocked because now once again it works fine. I put the logs back and lit it again and all good. I will do the close up and install the glass and surround and hope it continues to work.
Bob thank you again for your help.
ok put everything back together. used the fireplace last night for a few hours. tested it a few times. let it cool lit right up agian fine. thinking great now all is good. today tried it...lit for about 5 seconds and shut off:( will take off glass and see what is going on. maybe this is one of those intermittant faults?
arhh...sometimes it lights sometimes no. not sure what to do but try it a few times over next few days. maybe next time it wont light I will take logs out and try and play around with it. any suggestions are appreciated as always.
sometimes it wouldn't start and I would take the glass off and remove the logs and got her going and then put it back and worked ok. now I can't get it going at all. It has been very cold but that shouldn't matter? Maybe I need to check the new ground again? I shouldn't as it is wired well. maybe these units have some issues as mentioned above?
do you mean the unit that the remote controls? it does light each time for around 10 seconds then shuts off. does the control, control the valve based on the flame/heat sensor?
ok back at it. fireplace is doing the exact same thing as last year. I had a repair guy come look at it today and he says the control needs replacing. So I found this one: Amazon product ASIN B004H2MTWO
my fireplace is an Heat n Glo Escape 130C
It looks like this will work and can be returned if doesn't. what do you guys think?
Guy is going to call me with a price to get a control but this one looks like it would work. I also found this one which looks very similar to the one that is faulty. so not sure if I should trust this one;
any help is greatly appreciated