Mt. V AE Control Board Missing Parts

Brian1967

New Member
Nov 9, 2018
10
Caribou, ME
So I recently had to replace the thermocouple on my Mt. Vernon AS and noticed that the new TC seemed loose when I connected it to the control board (part# 7000-456 Rev C). The bad TC firepot error that I had been getting is now gone but the igniter now won't get hot. I brought the board to my local dealer who checked the fuse and said it was fine, and he also tested the igniter and said it was ok too. He noticed that the plastic connectors where the 2-pin wires connect to the board were missing and said this was what was causing my problem. He also said that I would not be able to find those connectors anywhere and would have to replace the control board at $700. I can't believe that there isn't a cheaper fix for this then replacing the entire control board. I've looked at my wires and the missing connectors are not there so I have no idea what happened to them but they are gone. I asked the dealer if he had an old board that he could pull those connectors off from and he did not. Does anyone have a suggestion of how to fix this issue? I've attached a picture showing the two two pin connectors where the plastic pieces are missing as well as the model number Tag.
 

Attachments

jzm2cc

Minister of Fire
Sep 25, 2014
533
Northern Michigan
Good grief. I'm sure you could find connectors like that on electrical supplier sites (Digi-key, Newark, etc). But if connector pins are making good connection to female connectors I'd just use a dab of RTV to hold connector to board. Keep it off the pins obviously. No way I'd replace a board, way too costly.
 
  • Like
Reactions: Ssyko

Brian1967

New Member
Nov 9, 2018
10
Caribou, ME
Good grief. I'm sure you could find connectors like that on electrical supplier sites (Digi-key, Newark, etc). But if connector pins are making good connection to female connectors I'd just use a dab of RTV to hold connector to board. Keep it off the pins obviously. No way I'd replace a board, way too costly.
 

Brian1967

New Member
Nov 9, 2018
10
Caribou, ME
I have not looked at those electrical supply parts stores that you mentioned because I have a feeling this is specific to this board. It's worth a shot so I'll do some searching and see what I can find, thanks for the advice.
 

kappel15

Minister of Fire
Sep 14, 2014
2,451
Iowa
I replied to your pm. kap
 

timlip

New Member
Nov 15, 2018
3
PA
I don't think you are missing any parts as my control board looks just like that. The first time I replaced the TC I was scratching my head as who would be dumb enough to put these very tiny and fragile prongs vs a plastic clip like all of the other connections. Today I find myself in the same boat, actually it happened almost two years ago(have been too angry at the stove needing yet another repair to work properly)...ignitor will not get hot. I pulled the board and checked the fuse, fuse is fine but the board is fried on the other side of the fuse..not sure how that could have happened but it did. I am not surprised as this stove has been nothing but a huge disappointment since day one...yearly I am having to make a repair to it. I have installed 3 ignitors, 2 thermos couplers, replaced a cracked baffle and now this. The amount of money I have had to dump into this stove is ridiculous. Thankfully I have saved myself some money by doing the repairs myself but I am beyond frustrated with it. I wish I never bought the damn thing..
 

Brian1967

New Member
Nov 9, 2018
10
Caribou, ME
So it turns out that one of the missing connectors was on the end of the old cable and with the new TC, I'm no longer getting the TC errors. Now my igniter won't get hot, replaced with a new one, still not lighting. The shop where we bought the stove checked the fuse and was good. Cables are all secure. Anyone know what else would cause a brand new igniter not to get hot?
 

kappel15

Minister of Fire
Sep 14, 2014
2,451
Iowa
Do you have power to the Wall control? If not, the fuse in the power supply box blew as it is for the igniter and dc power. You can check the 120 v wire harness from power supply to control board and see if you are getting power from power supply. Check connections on wire harness and power supply wire harness. kap
 

Brian1967

New Member
Nov 9, 2018
10
Caribou, ME
The wall control does have power. I'll probably check the power supply fuse anyway just out of curiosity . Wire harness from the power supply to the board looks fine, I disconnected it and plugged it back in, didn't help. Local dealer is checking to see if he has a wire harness that we can test to eliminate that possibility.
 

kappel15

Minister of Fire
Sep 14, 2014
2,451
Iowa
Continuity test on wire harness will do to see if good or not
 

kappel15

Minister of Fire
Sep 14, 2014
2,451
Iowa
Time to check connections on ignite wire harness. Is it one of those that has inline fuses? Maybe they are blown. I would double check the igniter too, that it is good. Just a continuity test or use a lamp cord and put ends on it and plug igniter into it. kap
 

Brian1967

New Member
Nov 9, 2018
10
Caribou, ME
The stove shop gave me a brand new igniter to try and it didn't work either. I don't think the harness has an inline fuse but I'll double check that too. Just about had it with this stove. I can start it with a torch but if I'm not here to restart it, the pellets will drop in and then get dumped into the ash pan when it doesn't light and the an older and smoke up the house.
 

kappel15

Minister of Fire
Sep 14, 2014
2,451
Iowa
If igniter isn't working, it shouldn't make smoke when it dumps pellets in ashpan. And if it does have the harness with inline fuses, there is one on each wire. And I have had new igniters that didn't work. I always test each one before I sell it, to make sure.If you have 120 volts in harness from power supply to board, then it has to either be the ignite harness or connections, or the igniter. kap
 

Brian1967

New Member
Nov 9, 2018
10
Caribou, ME
I have tested the wire harness from the power supply to the control board and it has the correct voltage. My igniter is still not working so I have been lighting it by hand and turning it off when I'm not here to restart it every time it needs to be restarted. It has to be either the control board itself or the wiring from the control board to the igniter. I have not tested these yet. Not sure there's anything on the control board I can test only the wire harnesses. Wish I had a better answer for you.
 

timlip

New Member
Nov 15, 2018
3
PA
I actually have mine working. Replaced fuse on circuit board then had to replace a broken prong for the thermo coupler. Drilled out the aluminum prong and replaced with a piece of copper wire. It's working for now. Hoping it holds up as I dont want to spend 600 on a new board.
 
  • Like
Reactions: kappel15

Brian1967

New Member
Nov 9, 2018
10
Caribou, ME
As it turns out, my issue was that both of the thin wires that go from the control board across the stove to the igniter were frayed and showing bare copper wire, one was almost broke completely. No idea how they got that way but a $15 replacement wire harness fixed my issue. Thought I'd let you all know.
 

kappel15

Minister of Fire
Sep 14, 2014
2,451
Iowa
Glad you found it, before you toasted the board. Thanks for updating us. Stay warm. kap