Vermont Castings Vent free Stardance UVS27 will not light main burner

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.

mbell

New Member
Nov 25, 2021
1
Brown City, Michigan
Hello. I have a freestanding Vermont Castings vent free propane Stardance UVS27 that we bought second hand. I don't know the age, but I do see 1997 in the ANSI number of Z21.11.2a-1997, which may reference the age? The problem is that the main burner will not ignite. The pilot light will light quickly and stay burning after holding the control knob in for approx 20-30 seconds. The pilot stays lit after releasing the control knob. The pilot flame is strong and blue and nicely surrounds the end of the thermopile. When I turn the control knob to the full light position, I hear a click or thunk in the valve area and the pilot light goes out. The main burner never lights. I have done the following troubleshooting:
- gas company verified proper gas line pressure to the stove and leak test
- I cleaned the thermopile all around with fine grit emery cloth
- I cleaned the pilot light opening and thermopile with q-tips using isopropyl alcohol
- vacuumed the inside of the firebox and burner area
- I tested the voltage from the thermopile to the gas valve terminals and it was at 750 mV while the pilot was burning
I do not know what steps to take next. Any suggestions or help would be greatly appreciated. Thanks!
 

Lennox65

New Member
Jan 29, 2021
75
New Hampshire
Hello. I have a freestanding Vermont Castings vent free propane Stardance UVS27 that we bought second hand. I don't know the age, but I do see 1997 in the ANSI number of Z21.11.2a-1997, which may reference the age? The problem is that the main burner will not ignite. The pilot light will light quickly and stay burning after holding the control knob in for approx 20-30 seconds. The pilot stays lit after releasing the control knob. The pilot flame is strong and blue and nicely surrounds the end of the thermopile. When I turn the control knob to the full light position, I hear a click or thunk in the valve area and the pilot light goes out. The main burner never lights. I have done the following troubleshooting:
- gas company verified proper gas line pressure to the stove and leak test
- I cleaned the thermopile all around with fine grit emery cloth
- I cleaned the pilot light opening and thermopile with q-tips using isopropyl alcohol
- vacuumed the inside of the firebox and burner area
- I tested the voltage from the thermopile to the gas valve terminals and it was at 750 mV while the pilot was burning
I do not know what steps to take next. Any suggestions or help would be greatly appreciated. Thanks!
The two times that I have encountered a similar problem, once the supply piping was undersized and the other time there was an obstruction of pipe dope (thread sealant) in the supply line. Have you checked the main burner orifice and piping for obstructions?