Jotul Sebago pilot goes out when burner ignites

random Posted By random, Jan 23, 2010 at 5:30 PM

Thread Status:
Not open for further replies.
  1. random

    random
    New Member 2.
    NULL
    

    Jan 23, 2010
    2
    0
    Loc:
    Adirondacks
    Hi all. First post, new to the forum. Thanks!

    I have a Jotul Sebago gas heater. I've found it shut off a few times recently. This latest time I spent a few minutes sitting in front of it observing. Here's what I found...

    When I light the pilot it appears normal.

    When I set the burner in the High position and turn it on the pilot flame dims and goes out in just a couple of seconds.

    When I set the burner in the Low position and turn it on the pilot flame stays lit. I can then gradually turn the burner up to High and the pilot stays lit. It's been cycling for about three or four hours now and seems to be working fine, even with the burner still on the High position.
     
  2. jtp10181

    jtp10181
    Minister of Fire 2.
    NULL
    

    Feb 26, 2007
    3,729
    3
    Loc:
    Madison, WI
    Prob needs the pilot cleaned out really well, and a new thermocouple.
     
  3. random

    random
    New Member 2.
    NULL
    

    Jan 23, 2010
    2
    0
    Loc:
    Adirondacks
    Thanks! I was hoping for some feedback before I took it apart in case I needed to have new parts on hand. I decided to just clean the pilot, and now the flame remains steady and strong. The thermocouple seems to be doing its job just fine so I didn't replace it. Thanks again!
     
Thread Status:
Not open for further replies.

Share This Page