Jotul Sebago pilot goes out when burner ignites

Post in 'It's a Gas!' started by random, Jan 23, 2010.

Thread Status:
Not open for further replies.
  1. random

    random
    Expand Collapse
    New Member

    Joined:
    Jan 23, 2010
    Messages:
    2
    Likes Received:
    0
    Loc:
    Adirondacks
    Hi all. First post, new to the forum. Thanks!

    I have a Jotul Sebago gas heater. I've found it shut off a few times recently. This latest time I spent a few minutes sitting in front of it observing. Here's what I found...

    When I light the pilot it appears normal.

    When I set the burner in the High position and turn it on the pilot flame dims and goes out in just a couple of seconds.

    When I set the burner in the Low position and turn it on the pilot flame stays lit. I can then gradually turn the burner up to High and the pilot stays lit. It's been cycling for about three or four hours now and seems to be working fine, even with the burner still on the High position.
     

    Helpful Sponsor Ads!





  2. jtp10181

    jtp10181
    Expand Collapse
    Minister of Fire

    Joined:
    Feb 26, 2007
    Messages:
    3,725
    Likes Received:
    1
    Loc:
    Madison, WI
    Prob needs the pilot cleaned out really well, and a new thermocouple.
     
    Collapse Signature Expand Signature
  3. random

    random
    Expand Collapse
    New Member

    Joined:
    Jan 23, 2010
    Messages:
    2
    Likes Received:
    0
    Loc:
    Adirondacks
    Thanks! I was hoping for some feedback before I took it apart in case I needed to have new parts on hand. I decided to just clean the pilot, and now the flame remains steady and strong. The thermocouple seems to be doing its job just fine so I didn't replace it. Thanks again!
     
Thread Status:
Not open for further replies.

Share This Page

Entire Site copyright © 1995-2016 - email to webinfo@hearth.com
Hearth.com and HearthNet are property and trademarks of Hearth.com LLC Advertising Information