Direct Vent Fireplace burner ports only partially light

OldSaltUSNR

New Member
Apr 26, 2020
11
Coeur d'Alene, Idaho
Looked up this prior thread, and I'm having almost the exact, same problem.

I have a Majestic (now "Vermont Castings") direct vent propane fireplace, installed and as far as I knew, working in 2017. I noticed over the past several years that the front ports weren't lighting, and figured it was because the rock wool "embers" had been improperly installed (by yours truly), covering one or more of the ports. I was going to get around to opening up the unit, cleaning it out, and fixing the problem, and "someday" was July 2020. After I'd removed the rock wool (and fake logs, and ornamental lava rocks), blew out the burner from the top (as much as I could, applying air pressure to each and every port, it still wouldn't light. Disappointed, would be an understatement. Shocked would be closer to my emotion.

So, through the wonderful world of the "interwebs", I found out about proper gas line pressure, bought a manometer, and sure enough, low gas pressure. The appliance plate states 11 inches at inlet, 10-10.5 inches at outlet. I was seeing about 9.5 inches at inlet. Went outside, and discovered the house second stage regulator had been factory set at 10 inches, whereas should have been at 11-13 inches. I bumped it to 12 inches (more is always better, right?)==c

Slapped everything back together, tested pressure at appliance inlet, 11 inches, tested at outlet, 10.5 inches, and we're in business - all fixed. Grabbed a beer, patted myself on the back, fired that baby up to see the rewards of all my hard work, and ...... no change. ;em (Ever seen a grown man cry into his beer? Yeah, that was the emotion I felt then.) So, I put my best problem solving skills to work, which meant grabbing more beer, and closing everything back up to "think about it" and come back with a better solution. (Hey, tactical retreat IS one way of problem solving. ;lol )

So, after enough time passed, (and my wife starting to nag about "are you ever going to finish that fireplace?"), I pulled the appliance apart, closed the fully open Venturi shutter on the burner, and applied 120 PSI of air pressure through the Venturi for ... a while ... in an attempt to clean out anything that might be blocking the ports. I haven't yet reassembled and tested the unit yet (that is NOT a trivial undertaking; lots of screws in tight places), but looking at that Venturi got me to thinking. (Note: The closest thing to a specification I could find said that propane Venturi's were supposed to be 1/2" open, and mine at full open (factory default) was about 5/8", so I did tweak that shut just a bit, as shown in the picture.)

Here's my first question: 1/2 PSI equals 14 inches of water, so gas is flowing through that tube at less than 1/2 PSI. That Venturi opening (there's one on both sides, which is probably standard) is one huge opening for heavier than air gas to flow through. I've never thought about this before (i.e. in regards to BBQ venturi's, etc.), but is 1/2 PSI enough velocity to push that gas through the tube (picking up air from the open shutter in the process), without dumping propane OUT of that hole? I mean, here I am adjusting the second stage regulator to ensure I have an extra 1-2 inches of water pressure, while I've got this gapping hole in the Venturi shutter ... just doesn't make sense.

So, back to the originally referenced thread. The OP said he tried DAKSY's recommendation, and it solved his problem. I've tried to push a q-tip inside both the supply hole of the Venturi (can't; obviously it has a device that reduces that gas flow, because the hole is blocked by copper) and the gas supply line. I found no obstructions there. When I blew out the burner via that Venturi opening, nothing obvious (like a cloud of dust) shot out of any of the burner ports, that I could see.

One last thing I tried was to check the burner (as installed) for level. It's pretty close to dead on level. I would have expected a slightly downward tilt (i.e. towards the front), since propane flows in course with gravity.

So, before I reassemble and test this thing, does anyone have any other suggestions? I'm not optimistic that this "disassembly & blow out" process did anything to improve the situation, and I'm out of ideas.
To recap:
  • See attached pictures of the burner, the Venturi, and burner when lit. The area marked in red are the problem port areas.
  • Originally, the area in the burner picture marked in read, upper middle of the burner, failed to communicate flames to the other ports, as well. I did the unthinkable, and took the next sized larger drill bit and made those ports from back to front just a tiny bit larger, i.e. barely shaved any metal at all. Now they flare a bit, but the flames travel to the forward ports, but not completely.
  • Checked gas pressure, and ensured it's at spec.
  • Checked and cleaned each individual port with a properly sized drill bit.
  • Disassembled and blew out burner from Venturi.
  • Checked gas supply line that connects at Venturi for debis.
  • Note: All ports supply propane. I can easily light every one with a butane lighter.
  • If this doesn't work after reassembly, I'm gonna need a whole lot more beer.;sick
Thanks for reading, and thanks in advance, for your assistance.

burner_lit_LI.jpg
burner_LI.jpg
Venturi.jpg
 
Last edited:

OldSaltUSNR

New Member
Apr 26, 2020
11
Coeur d'Alene, Idaho
Did you pull the burner orifice & clean behind it?
Are you speaking of where the Venturi connects to the burner (i.e. three screws, gasket at the bottom of the burner)? Or, the brass piece that screws into the Venturi (if that's removable; haven't tried to remove it)?

There's no other possible removable parts that I can see in this unit. Thx
 

OldSaltUSNR

New Member
Apr 26, 2020
11
Coeur d'Alene, Idaho
Ok, I "found" and removed the burner orifice. It's clean inside and out. I can see through it. The Venturi tube behind it is clear. I even pulled off the Venturi from the bottom of the burner and looked inside there. As I expected, it's nothing other than two pieces of metal welded together with a half to three-quarters inch gap between them, i.e. essentially an empty tank, void inside, with holes on top of it.. I could see how one port might get blocked, but not a whole entire front section, or multiple ports, because they aren't ports on a metal tube which could get blocked. It's remarkably simple technology, which makes this issue all that more frustrating. There's little to no pressure. The gas pipe dumps to the valve, which runs gas via a tube to the Venturi oriface, which (presumably, through compression thru the smaller hole) accelerates the gas through the Venturi tube, adding air to the mixture, dumps it into the burner, and seeps out through the holes in the burner.

I'm going to reinstall the burner, and try to make sure it's tilted slight forward toward the ports that won't light, so that gravity might help the propane move to the holes that won't light.

I'm rarely stumped with neither a solution nor a "question" to answer. The only complicated part of this unit would be the gas valve, and it's delivering the proper outlet pressure when the thermopile is hot.
 

DAKSY

Patriot Guard Rider Moderator
Staff member
Yes, the brass hexagonal fitting at the bottom of the your burner tube, adjacent to the air shutter.
The tube BEHIND that, between the valve & the orifice, is the location where spiders like to build nests.
They can partially or fully block the gas flow to the burner. If that flow is reduced, there won't be enough
fuel to get to the front of the burner...
Let us know what you find.
 

OldSaltUSNR

New Member
Apr 26, 2020
11
Coeur d'Alene, Idaho
I pulled it apart and checked it again. Nothing came out with a Q-tip, and everything that I could visually inspect was clean. The tube from the control valve to the burner passes though the sealed fireplace floor, which was more work than I wanted to do to remove it (plus, I have to find some high temp rtv to reseal it; the highest rated RTV that I have been able to find is 800F, and I'm not sure that's high enough, as fireboxes can exceed 2000F). I reconnected the burner, closed and tested the input/output gas ports and leak tested, fired it up, and no change.

So, I guess the next step to tear the whole thing down, remove the fireplace floor "door", remove that burner tube from the valve, blow it out, and maybe replace the valve "just because", i.e. I don't know what else to do. The obvious conclusion if the gas pressure(s) are correct and gas isn't flowing properly to the burner ports, is "something's blocking the gas flow somewhere", but I'm out of things to check. The burner assembly is not an available part, FYI, so I've got to go with what I have. I cleaned the thermopile at the start of all this, but haven't tested it (i.e. proper voltage when hot), since the valve has been opening fine once the pilot is lit. However, I can test the ignition assembly "while I'm in there".

I've read a few web posts about excessive air flow into the firebox blowing out or preventing a burner from igniting. There are three large ventilation holes (i.e. coke can sized) in the bottom back of the unit, which are deflected by baffles. The intake/exhaust venting is "normal", i.e. duel walled piping vented horizontally out the back of the unit. So, although this is a possible concern, I don't see it being the issue. (I've tested with and without the glass installed, and port ignition is the same either way, but obviously, there's more airflow-breeze interference with the glass off.)

Once again, there IS propane flow from every, single port, if I light them manually. The flames just stop spreading from one port to the next.
 

Millbilly

Member
Dec 13, 2015
161
02648
Dont just blow air through the burner line. You need to actually look though it. The spiders leave a silky sticky material that gets stuck in the corrugations. Try pipe cleaner or a small screw driver.