Heat & Glo Gas Log Fireplace Won't Light

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Jul 19, 2023
TL;DR: It worked just fine two days ago but now nothing happens when turning it on. Is there anything I can try before calling in an expert?

I'm house-sitting for relatives for a few months while they are overseas. They have a gas log fireplace so, being winter here, I turned it on the first night for a couple of hours. No issues so far, it worked great.

I tried again two nights later and got nothing. The remote shows the fireplace to be 'On', but there is no flame, nor fan, nor any other signs of life. I'm not keen on giving the impression that I broke their fireplace after one night, so is there anything I can try before calling in the experts? My first thought was to check the pilot, but this model doesn't have a constantly lit pilot. I also replaced the batteries in the remote. That was about all I could think of.

Any suggestions would be appreciated. Cheers everyone.

Model: I30X-N-AU

IMG_20230719_214622834.jpg IMG_20230719_222449025.jpg IMG_20230719_222520447-1.jpg IMG_20230719_142330818_HDR.jpg IMG_20230719_214754038.jpg
Last edited:
3 possible causes and the corrective actions

-Control module is not in “REMOTE” mode: Ensure module switch is set to REMOTE.

-Control module and remote control are not programmed to each other: The control module will beep when it successfully receives a command. If it does not beep, clear module memory and reprogram wall switch.

-Control module is unplugged. In case of power outage, backup batteries are depleted or missing: If the transmission indicator comes on when power button is pressed, verify that the control module is plugged in the fireplace junction box located in the controls area. Also verify that the batteries are installed in the battery pack