Mt Vernon Ae Stuck on Autoclean, Wiring stinks too

  • Active since 1995, is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Oct 31, 2022
Mahopac, ny 10541
Purchased this stove in 2008. Only once would the seller come to my house for repair otherwise he was willing to give me all the info to fix the stove myself.
Every time it came down to scrap the fire pot or replug the unit.
Well scraping and installing a wall switch to reboot this stove never worked
There is some threads about this but they are incomplete or closed like the problem is solved
I took apart the fire pot and disconnected it from ash pan motor. After grinding it shiny and replacing, still no fix.

So having seen something about the microswitch assembly in the ash pan motor assembly, I purchased and replaced this switch.
It's hard, time consuming and a lot of trouble to access.

First, to disconnect the ash pan arm under neath the stove where you clean out the ashes - the top of the screw is a metric hex head and the bottom nut is around 11mm . Its easier to hold the top of the screw when the fire pot is removed but not necessary. The screw has a shoulder on it so you can't tighten down to hard so the arm won't function.

Second, you can unscrew the bolt holding the motor assembly with a long socket extension and i think it was 11mm socket

Third, to access the motor i did the following
a- removed side panels and rear panel ( disconnected stove pipe to remove rear cover.
b- remove computer board by pressing on clip at top to release it from bracket - note at least 4 wire assemblies were disconnected so mark and label before removing
c Unplug and disconnect fan connection blower assembly
d Finally remove screws on metal pan to access the auto clean motor disconnect wire from control board
e- Remove screws on motor assembly will give access to the microswitch

Note The old microswitch was properly reading closed even though i had auto clean error. I didn't like the way I found the two black wires for the ash pan motor. They were folded over and right under the motor - possibly getting pinched causing a signal error or interference .

So after reassembly, the stove has been flawlessly working. Not sure if just moving the wires instead of changing the switch would have worked. If that didn't work i was ready to change the wiring harness assembly which costs about $88. The microswitch was $20

Also, in general the electrical connections suck on this stove. My thermostat goes out / blank. To get it back on, i jiggle the thermostat wires where they go into the stove. When trying to solve this problem with my dealer, he acknowledged a problem and said to cut the ty rap inside the stove holding those wires together. Again another solution that hasn't worked for me. Right now i haven't tackled that problem but if i do ill hard wire it in or maybe look to change the terminal block to a more reliable one

Good Luck with this stove . For $4000 i expect a lot more
Ya, wall control going blank has been an issue. It is the cheap grade tstat wires they use. I've wiggled mine a time or two, and cut the ends off and re-attached the wires, which helped. Others have gotten a heavier grade tstat wire. By the way, nice repair on your other problem. Stay warm. kap