Pellet stove shutting down

Jc3 Posted By Jc3, Nov 8, 2018 at 1:05 PM

  1. Jc3

    Jc3
    New Member 2.
    NULL
    

    Nov 8, 2018
    3
    0
    Loc:
    Maryland
    Whitfield optima 30 starts runs for a few min. Shuts down . Photo eye clean, blower blows air but after a few min. It use to automatically kick in and blow harder. Not doing that and stove shuts off. Auger is feeding fine.
     
  2. Ssyko

    Ssyko
    Minister of Fire 2.
    NULL
    

    Nov 6, 2017
    1,371
    298
    Loc:
    Lorraine NY
    Ck your low limit snap disc, on or near you exhaust housing/combustion blower. Connect the two wires together and see if stove works normal. When you do anything in the back or with wire always unplug the stove first. When was the last thourough cleaning done? May be a vacuum issue also
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Jc3

    Jc3
    New Member 2.
    NULL
    

    Nov 8, 2018
    3
    0
    Loc:
    Maryland
    Thank you I’ll try that , stove has been cleaned
     
  4. Overfireinthehole

    Overfireinthehole
    Member 2.
    NULL
    

    May 5, 2017
    240
    56
    Loc:
    Miller MO
    Optimas use a photo eye for POF, not a low limit.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Jc3

    Jc3
    New Member 2.
    NULL
    

    Nov 8, 2018
    3
    0
    Loc:
    Maryland
    Tested both disc on my stove, didn’t work ,stove still shuts down the heat blower fan is new , when stove starts fan speed won’t change when I try. Photo eye clean . Could the electronic board be bad?
     

Share This Page