Quadra-fire contour no blower operation

Coltontvb

New Member
Feb 4, 2018
11
Canada, Northern Ontario
I recently installed a new snap disc (#1) and convection blower as it was noisy and the snap disc terminal was faulty. After installation of the new blower and snap disc the blower worked for about 1 week before it quit. The stove lights, feeds and runs until the thermal snap disc sets, the pellet stove is overheating due to the fact that the convection blower is failing to turn on. I tested for power at the snap disc and had none (voltage), just to be sure, I jumped the snap disc with a fused jumper wire and the fan still did not turn on. I tested the fan to ensure the fan was okay by applying outlet power to it, the fan turns on and runs as required. Is my failure in the control box? According to the wiring diagram in my manual there are no fuses to stop any possible shorts or voltage spikes to the control box, the only other test I can think of to completely ensure that the box is okay is to test the control wire from the box to the snap disc for an open. Also as far as I understand the ground side is switched by the Hi-Med-Lo switch, which also runs the auger and combustion motor, which leads me to believe that that portion of the circuit is working as intended as well.
 

Ssyko

Minister of Fire
Nov 6, 2017
3,035
Lorraine NY
with the stove unplugged, try removing the control box and reinserting a couple times may be a dirty contact. if it does not do anything, test for power on the hot side of the snap disc wire and look for worn insulation on the wire all the way to the box. if it has shorted out someplace it very well could have damaged the board. although a worn, high amp draw motor could also damage the board. but lets see what you find.