Snap disc not activating the convection fan.

  • Active since 1995, is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.

Barry C

New Member
Oct 3, 2022
Quadrafire, 1200 Classic Bay Insert. Newly refurbished by a dealer.

I have gone back and forth with the seller with a warranty, for parts only.

I have been sent two different snap discs, one for 135 f and one for 125f. The lower one was supposed to make it fire off sooner.
3 switches did not activate the fan.
The stove fires up fine, goes to temp, 200f+ inside the cleaner lever slots.
Control box has the call light on.
Switch is firmly and tightly attached to stove body, tight wiring connections.
Pulling the purple wires and jumping a connection, the fan runs.
Removed the switch and when connected to the wiring, the fan runs with heat applied to the switch. It cooled off and fan shuts off.
Repeated steps got the same result. None of the 3 switches triggers the fan, when mounted in the stove.
Anybody want to help me chase this down?

If it works the way you say then the mounting point is not
getting hot enough to turn the fan on. If the inside of the
stove, where the sensor is mounted, is plugged with ash
( an excellent insulator) it will take a long time to get hot enough
to start fan
  • Like
Reactions: ARC and kchace
One of my thoughts that I did not follow up on, it fell on deaf ears of the tech who seemed to dismiss it. The stove got hot enough to shut down when it hit top temp, over 250. Something was stopping it from feeling the heat.
Thanks, I will give it a try tomorrow.
OK, so I gave that a try and there was/is no ash in that area. I removed the tube cover panel and could not see that snap switch but that place was clean. Removing the switch, behind it is clean, no ash. I put the vac next to the opening and let it vac. The stove got hot, no convection fan. I did the line connection/jumper wire from the switch wire and the fan ran.
If you jump the switch and the circulation fan works, replace the switch
You can also test it with an ohmmeter. Heat the switch with a lighter,
a candle or some other heat source to see it opens and closes as it heats and cools.
If you jump the switch --the blower works
if you heat the switch -- the blower works
process of elimination -- where the switch is mounted does not get hot enough
to activate switch
Conclusion --- The Stove is plugged with ash, needs a teardown and cleaning
or try the leaf blower cleaning
This is a professionally rebuilt stove, used one season, not that much. It worked, I vacced it daily, never failed, now when trying this fall, it is doing this.
OK, so leaf blower. Are we talking just blasting the stove in and out? Compressed air?
Leaf blower trick search for it on this site
I don't have a leaf blower but I have a compressor and will give that a try.
My most recent thought is that a mud wasp got in there.

In my last test/effort, I pressed the wired up switch, onto the outside surface of panel where the switch mount hole is. On and off went the switch as it heated and cooled.
Two suggestions if you try compressed air
1 Take the stove outside or your better half will not be a happy camper
Dust (ash) everywhere
2 disconnect the vacuum hose at the stove so as not to over-pressurize the switch
  • Like
Reactions: ABusWrench and ARC