• Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Nov 24, 2020
Herndon, VA
I have a Whitfield Advantage II-T pellet stove. The blower fan has a problem in that it cuts off when I increase the speed. If I start on the lowest speed setting for the blower, I can gradually increase the speed using the dial, and the I can hear that the fan speed increases. When I get to about half way on the dial, the fan hums, and stops spinning. I have replaced it with a brand new fan, and the problem persists. I also replaced the high limit snap switch, but that did not help either.
Any ideas as to what would cause this?
Try some contact cleaner or deoxit, unplug the stove and spray the potentiometer and rotate it a few times then allow it to dry out and try it. Sounds like it’s dirty or getting worn out.
This is a photo of the potentiometer. It is completely enclosed and soldered to the circuit board. I'm not sure it can be cleaned. Thank you.

Last edited:
A little cleaner down the side of the button
work the switch. Add cleaner and work again
do this 6-8 times and see if that helps.
clean mine every year never had a problem with it
  • Like
Reactions: BarryDrez
Apolgies. I attached the wrong image. The correct one is now attached. I tried cleaning as suggested. Unfortunately, it didn't help. I'm not sure if the cleaner is getting inside the potentiometer.
well id try connecting the blower motor directly to the outlet and let it run for a while and see if it slows or becomes intermittent. and change the pot in question if cleaning does not help.
  • Like
Reactions: BarryDrez
I'm sure Digi-Key or Dell Electronics will have the correct replacement.
  • Like
Reactions: BarryDrez
Hook the motor to an old lamp cord and plug it in the wall outlet and see if it runs for 30 min, if it does, the pot may be the issue.
I tested the fan. It is fine. I am not good with soldering. i don't think I want to attempt to replace the potentiometer. I'll have to see if I can find someone to do that for me.
This guy repairs those old Whit control boards--
This guy repairs those old Whit control boards--
Thanks, but I don't want to pay $150 just to have a $4 potentiometer replaced.
Hello. Did you ever get your stove working. My stove is doing the exact same thing and I’ve tried everything suggested. Please let me know if you got yours working.
No, unfortunately I did not. My stove is almost 30 years old. I have replaced the blower fan, the auger motor and other parts. I am going to finally bite the bullet and get a new stove. Good luck with yours.