Brand New PelPro PP130 Issues

vitality62 Posted By vitality62, Dec 15, 2018 at 10:14 AM

  1. vitality62

    vitality62
    New Member 2.
    NULL
    

    Dec 15, 2018
    3
    0
    Loc:
    ny
    hi i am new to this forum and i feel like i shouldnt be here this soon. ive been having pellet stove issues for months now so i broke down and purchased a PelPro PP130. Super excited when it came in i bought a bunch of pellets. I read the user manuel to make sure i didnt mess anything up. I did its first launch cycle to prime the stove the blower kicks on everything works normal. Well i tried the sequence 3 times and all i get is a red light flashing 4 times reading "missed ignition". well after being very frustrated because i started off so excited and confident this time i went to bed figured id try to ignite my own fire in the morning like everyone tells me the ignitor has nothing to do with how it runs after its lit. So i started a fire got it rippin it says to keep it on high for 30 min then shut it off and let it cool. I had a bonfire in this thing for 30 minutes 0 fan kicked on i can fry an egg (or my hand) on the side of it. i let it fully cool down and wanted to try again now that the paint is cured and i wont be smoked out. i manualy light a fire again got it rippin.. put the setting on 6 rather than high, it ran for 55 minutes straight got hotter than the previous run still no fan to blow heat out. the only time the fan kicks on is during the ignition process and once i start a fire and it gets going the fan shuts off assuming its waiting for the entire unit to warm up well at this point i can almost fry an egg on the backside now i know something isnt right. i am extremely dissapointed trying to keep my cool because i am very hot headed when it comes to spending this much cash on something that has 2 or more problems brand new i have 0 patience and i am hoping somebody here can help me please i live in the adirondacks and its usually 5 degrees outside luckily it is 40 right now. thank you, john
     
  2. zrock

    zrock
    Minister of Fire 2.
    NULL
    

    Dec 2, 2017
    691
    155
    Loc:
    bc
    I would call the place you bought it from.. This is why u have warranty
     
  3. vitality62

    vitality62
    New Member 2.
    NULL
    

    Dec 15, 2018
    3
    0
    Loc:
    ny
    i know the site says saturday 9am-2 but i called and it says monday thru friday only so i came here in the meantime
     
  4. zrock

    zrock
    Minister of Fire 2.
    NULL
    

    Dec 2, 2017
    691
    155
    Loc:
    bc
    I would not mess with it... could screw u out of warranty

    Sent from my SM-G903W using Tapatalk
     
  5. vitality62

    vitality62
    New Member 2.
    NULL
    

    Dec 15, 2018
    3
    0
    Loc:
    ny
    probly a good idea just wasnt sure if anyone here would know if it was something stupid i can fix myself. ether way its getting brought back to tractor supply for my money back if they cant diagnose it over the phone monday, even as charred as it is lol!!!!!:ZZZ:ZZZ:ZZZ:ZZZ
     
  6. Ssyko

    Ssyko
    Minister of Fire 2.
    NULL
    

    Nov 6, 2017
    2,215
    530
    Loc:
    Lorraine NY
    One thing you could try that wouldn’t mess with your warranty is to unplug the stove for a min or two, plug back in and may reset your control board. If you haven’t already done that:)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. xseabee

    xseabee
    New Member 2.
    NULL
    

    Nov 14, 2018
    3
    0
    Loc:
    upstate NY
    I had same problem . Fan wasn't plugged in. It has a quick connect that wasnt connected. Inside right panel.
     
  8. mr meener

    mr meener
    New Member 2.
    NULL
    

    Aug 11, 2017
    27
    1
    Loc:
    NY, USA
    I do not know much about your stove but a Harmon set on stove temp manual burn instead of auto would do the same as your stove is doing
     

Share This Page