Champion 2000W Inverter Generator No Output

gfreek

Minister of Fire
Nov 5, 2010
1,420
Attica,,New York
It's a enclosed "cube" generator, I have zero output, runs wide open, throttle is electronically controlled. Anyone know how to troubleshoot this starting with output from the generator before the inverter control box ?
 

ABMax24

Minister of Fire
I'm assuming you've tried resetting the circuit breakers and GFI?

Does the green output light illuminate when the engine is running?
 

gfreek

Minister of Fire
Nov 5, 2010
1,420
Attica,,New York
No Green light when running.. pushed resets.. It was fine this spring and had output.. As soon as I fired it up no output before any load applied, no auto idle.. Also partially disassembled and checked connections..
 
Last edited:

Highbeam

Minister of Fire
Dec 28, 2006
18,731
Mt. Rainier Foothills, WA
No Green light when running.. pushed resets.. It was fine this spring and had output.. As soon as I fired it up no output before any load applied, no auto idle.. Also partially disassembled and checked connections..
I’ve owned multiple champion generators. Call them up or email them. They’re in California. I’ve found them to be very helpful.
 

ABMax24

Minister of Fire
My assumption is the control board is faulty, as Highbeam suggested call up Champion, they will guide you through the process.
 

gfreek

Minister of Fire
Nov 5, 2010
1,420
Attica,,New York
Yup. I'll call them Monday and post...
 
  • Like
Reactions: Highbeam

Rob711

Feeling the Heat
Oct 19, 2017
412
Long Island, ny
Any luck? I have a 9k champion. It was slightly off when new. The hertz and voltage was not where it should have been. I called them, they told me a local place I could take it to under warranty. Then explained exactly how to correct, I believe they sent a email explaining the process. Point is they had great customer service. Good luck!
 

gfreek

Minister of Fire
Nov 5, 2010
1,420
Attica,,New York
Well, I talked to a tech rep yesterday, and told me I needed a new inverter control box. He had trouble looking up the part number, superseding, and was supposed to call me back within 20 minutes. As of now I've heard nothing. I also just sent them Email for part..
 
Last edited:

gfreek

Minister of Fire
Nov 5, 2010
1,420
Attica,,New York
So still have not heard back yet. Been busy getting estimates from power surge to file a claim against NG power company. On the agenda to call them today.. If I get no luck there I may try the vendor I purchased from originally, still selling on Ebay..
 

Rob711

Feeling the Heat
Oct 19, 2017
412
Long Island, ny
That’s a bummer to hear, I guess champion customer service has declined in the last ten years. I was looking at those little generators, went with Honda 2200.
Have you tried a email stating what you steps you have taken so far? Good luck
 

gfreek

Minister of Fire
Nov 5, 2010
1,420
Attica,,New York
Talk to them via phone today, different rep, Told me to first try a control module for the ignition, even though it runs ,can affect output. So that's coming $32. Holding off on the Inverter control module @ $155 plus s/h..
 
Last edited:

gfreek

Minister of Fire
Nov 5, 2010
1,420
Attica,,New York
Installed Ignition module assy.


Still no output. Need to call them back, not today, it's like summer.. Was able to find parts and wiring schematic & part # for the inverter control unit, when I punch it in it shows not available, but I see it's available in Canada. So will see...