• Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Oct 8, 2022
Chelsea, VT
We moved into a new home last year with a Quadra-Fire Castile pellet stove. It worked great last winter, no issues other than occasionally needing to hit the reset button. This year, however, it has had issues feeding and igniting. The thermostat flashes "HEAT", the red call light comes on, and sometimes the exhaust will start but not usually. Then it just doesn't feed pellets or ignite. When I press reset, the exhaust fan starts, it feeds, ignites, and then stops feeding again. We have cleaned it thoroughly, adjusted the thermocouple, and checked the vacuum system to the best of our abilities. Today, the thermostat called for heat, but the call light didn't come on and pressing the reset button got no response. I unplugged it and plugged it back in, and it started up, but I yet again had to hit reset to get it to feed and ignite.
Try jumping the thermostat terminals on the stove and see what happens.

Did you try unplugging the unit and pulling out the control board and reseating it? Only do this after unplugging the unit!
I had the same sort of problems with mine.

Here is the thread:

Read my final post. It may surprise you. It did me! But now it works as it should. Good luck.
I would also check your exhaust pipe if it hasn't been cleaned recently and it goes horizontal through the wall it may be full of Ash causing low vacuum.