PSG Caddy wood/electricity furnace blower issues

Caddy Posted By Caddy, Mar 11, 2017 at 7:33 AM

  1. Caddy

    Caddy
    Member 2.
    NULL
    

    Mar 11, 2017
    17
    3
    Loc:
    Quebec
    Good morning!

    I had a PSG caddy wood/electricity furnace installed 1 month ago and I'm really satisfied with it so far.

    Since yesterday I have a problem with the blower. When the blower is at speed 6, it doesn't work correctly and make a big roaring sound.

    Its look like that it doesn't push the hot air out of the plenum, because the plenum sensor rapidly says that it is to hot !!!!

    I can't seem to find the problem except that the blower would be broken.........

    If you have any suggestion what to look for let me know !!!!!!!!!!!!!!!
     
  2. brenndatomu

    brenndatomu
    Minister of Fire 2.
    NULL
    

    Aug 21, 2013
    3,991
    1,459
    Loc:
    NE Ohio
    Hi Caddy!
    Does it do the same thing when running on both wood or electric?
    Sounds like there may be a bearing issue with the blower...do you think the plenum temp sensor is working correctly...as in the plenum is actually getting very hot?
    I'd give your dealer a call...or maybe PSG (SBI) they have been generally pretty helpful when dealing with issues on the Drolet product line
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. maple1

    maple1
    Minister of Fire 2.
    NULL
    

    Sep 15, 2011
    9,853
    2,077
    Loc:
    Nova Scotia
    Get your installer back to check it out.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Caddy

    Caddy
    Member 2.
    NULL
    

    Mar 11, 2017
    17
    3
    Loc:
    Quebec

    He coming monday.... but mean while maybe some one had an idea....
     
  5. Caddy

    Caddy
    Member 2.
    NULL
    

    Mar 11, 2017
    17
    3
    Loc:
    Quebec
    Only wood because when on the electric, the blower works at speed 4.....

    I checked all the blower speeds, and its stop working correctly ONLY at speed 6.....

    The plenum temp seems fine too....

    I guess i'll have to wait till monday hehe....
     
  6. STIHLY DAN

    STIHLY DAN
    Minister of Fire 2.
    NULL
    

    Jan 15, 2013
    1,427
    552
    Loc:
    So NH
    Change the blower speed.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. brenndatomu

    brenndatomu
    Minister of Fire 2.
    NULL
    

    Aug 21, 2013
    3,991
    1,459
    Loc:
    NE Ohio
    I don't think it can be changed on the newer ones...with out fooling around with the board anyways.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Caddy

    Caddy
    Member 2.
    NULL
    

    Mar 11, 2017
    17
    3
    Loc:
    Quebec
    The blower speed can t be changed. Even the tech cant find the problem... Caddy is trying to dublicate the problem in their shop in or to resolve it
     
  9. MaxK98

    MaxK98
    New Member 2.
    NULL
    

    Feb 20, 2018
    1
    0
    Loc:
    Qc
    Caddy,

    My friend is having the exact same issue with his Caddy furnace. Did they find out the issue?

    Thanks
     
  10. Mrpelletburner

    Mrpelletburner
    Minister of Fire 2.
    NULL
    

    Jan 20, 2011
    523
    139
    Loc:
    Mass
    How is the caddy working for you? What are you burning for fuel and what are you seeing for burn times?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. Caddy

    Caddy
    Member 2.
    NULL
    

    Mar 11, 2017
    17
    3
    Loc:
    Quebec
    Its working fine... i would say i'am still learning how to operate it....

    I am burning ash tree. Whe its -20 c I reload it about every 3 hours.... if warmer it last all afternoon
     

Share This Page