Hello,new stove new member,go figure?!?!?Two week old Castile insert works great 1/2 the time ...

Status
Not open for further replies.

Fatt68Hogg

Member
Apr 17, 2016
2
Fogelsville PA
Hello,new stove new member,go figure?!?!?Two week old Castile insert works great 1/2 the time,call lights on but no action until I move thermostat or hit reset?!?! What gives?
 

Lake Girl

Moderator
Nov 12, 2011
6,940
NW Ontario
Changed your title a bit as you want to catch other Quadrafire owners eyes! You may want to check the thermostat line to ensure connection and no damage on the line. I know they have had problems with thermostats for some of the stoves but can't remember which ones. Since it is new, talk to your dealer. If kappel15 or DMKNLD show up, listen to their advise...

Welcome to the forum!
 

Fatt68Hogg

Member
Apr 17, 2016
2
Fogelsville PA
Changed your title a bit as you want to catch other Quadrafire owners eyes! You may want to check the thermostat line to ensure connection and no damage on the line. I know they have had problems with thermostats for some of the stoves but can't remember which ones. Since it is new, talk to your dealer. If kappel15 or DMKNLD show up, listen to their advise...

Welcome to the forum!
Thanks Lake Girl.I did check both ends of wire connections,seemed fine.Im going to hook up digital thermostat anyway maybe that will do it. Like I said its an older thermostat. And yes I have read endless blogs with kap and dmk.
 
  • Like
Reactions: Lake Girl
Status
Not open for further replies.