log splitter has no force

Status
Not open for further replies.

Turner87

Member
Mar 4, 2015
17
Indiana
I have a MTD 25 ton log splitter with a 5hp briggs. This year I replaced the pump with a 11 gpm dalton hydraulic pump. Ram moves in and out but when it hit the log it will not kick down. Like it won't build up any pressure. I'm kinda stumped on what to do. The pump looks like the one I removed. Figured it would be rated the same.
 

Jags

Moderate Moderator
Staff member
Aug 2, 2006
18,146
Northern IL
You are having a bypass issue. Usually caused by either bad seals on the ram or pressure relief valve issues.
 
  • Like
Reactions: JTRock

duramaxman05

Feeling the Heat
Aug 17, 2014
438
Perryville, Mo
Does the engine stall or bog down?
 

Turner87

Member
Mar 4, 2015
17
Indiana
The engine doesn't bog down. Coupling is good just installed a new one.How can I check the seals in the ram? Or the relief valve?
 

triptester

Feeling the Heat
Aug 25, 2006
359
S.E.Wisconsin
A 2-stage log splitter pump has two sections. One section contains a small pump which sends fluid to the system at all times when it is turning, when there is resistance to flow pressure will build until the relief in the control valve opens or the engine bogs down. The second section contains a larger pump which sends fluid to the system until a preset pressure is reached, usually 600-900 psi, at which time the fluid from the larger pump is returned to the suction side of the pump.

If the cylinder is moving and the pump has a solid connection to the engine the only things that keep pressure from building is a open relief in the control valve or bad seals in the cylinder.

Adjusting the pressure setting on the pump will not solve the present problem.
 

JTRock

Burning Hunk
Aug 3, 2014
237
CT
You are having a bypass issue. Usually caused by either bad seals on the ram or pressure relief valve issues.
I'm a hydraulic shop foreman. This is correct info. It's USUALLY internal bypassing, or your pump. If it's leaking internally and your gland packing is good you can't see it. We have standard repair charge of $295 To repack a log splitter. They are quite simple in their seals.
 

kevin j

Minister of Fire
Jan 21, 2008
688
minnesota us
What was the original problem why you changed the pump?
Do you have pressure gauge installed?
Then we can go through easy cylinder test. Takes a lot of cyl seal leakage to have 'no pressure' buildup

Can only be not generating flow, or moving flow to tank with very little resistance to that flow.
 

Turner87

Member
Mar 4, 2015
17
Indiana
I replaced the pump because the top seal blew out and MTD don't sell replacement parts. I do not have a pressure gauge. I tried adjusting the relief valve on the handle and it didn't change much. The pump doesn't have adjustments. Where should I install a gauge?
 

triptester

Feeling the Heat
Aug 25, 2006
359
S.E.Wisconsin
Install the gauge between the pump and control valve.

The reason repair parts are not available for 2-stage log splitter pumps is that the average hourly repair rates at a hydraulic shop would exceed the replacement cost of a new pump.
 
  • Like
Reactions: JTRock

notshubby

Member
Mar 26, 2015
139
constantia ny
installing a guage between pump and valve will not tell you which component is bad only that system pressure is low. attach guage directly to pump output, deadheading it start briefly watch pressure build until it no longer rises. or motor starts to bog down. then shut down. don't run more than a cpl seconds at full pressure. most splitter pumps will make between 2000 to 3000 lbs. if pump makes pressure move on. even 1500 lbs should split straight grained wood.

install guage on the valve where the hose that runs to the power side of cylinder (the backside or side that doesn't have the ram coming out of it) would be connected. drop hose you disconnected into 5 gallon pail (preferably one with a lid with a bung hole as there may be some splashing ) start splitter put handle in extend position watch guage. guage should go up. no appreciable amount of fluid should come out of hose at this point unless you have handle in wrong direction. shut back down. if your getting good pressure hook that hose back up run ram to extended position. shut down and remove other hose.

now that you know you have good pressure at the pump and at the valve if it still wont move its most likely the cylinder. start her back up put handle back in extend position and see if it pushes fluid through the cylinder and into the bucket.

one other suggestion I can make judged on the comment that "pump looks like old one". if you bought it on ebay or something to save money (nothing wrong with saving a few bucks) make sure it is the right rotation. cw vs ccw. if its wrong it would fail the pump test at step 1 anyway.
 
Last edited:

Turner87

Member
Mar 4, 2015
17
Indiana
After talking to a local hydraulic guy, he said the valve is most likely what's wrong. Well replaced the valve today and still doing the same. I did some test on the cylinder, with a piece of wood in the splitter I removed the return hose, started the engine and move the control forward to split wood when the ram hit the wood fluid was still coming out. So I'm pretty sure it's the seals in the cylinder. Has anyone ever done this test to confirm?
 

kevin j

Minister of Fire
Jan 21, 2008
688
minnesota us
Which return hose?
Return from valve to tank will have fluid coming out at small section pump flow of two or 3 gallons a minute

If you disconnected hose from rod side of the cylinder back to the valve that should not have fluid coming out of the cylinder.
 
  • Like
Reactions: Jags

golfandwoodnut

Minister of Fire
I had a similiar problem and thought the pump was bad and bought another one. It turned out I needed to change the connector to the tank to fit the new, bigger pump. when I did I found a plastic thing in the line blocking the line. I removed the blockage and it fixed my splitter. Just saying something could be blocking the line.
 
Status
Not open for further replies.